1

Chrome 53 Bug Affecting Symantec SSL/TLS Certificates

Created on Nov 10 2016, 11:42 PM by Unknown

We’ve been made aware of a bug in Chrome version 53 that affects some Symantec, GeoTrust, and Thawte SSL/TLS certificates resulting in an error display when visiting affected websites.  There are no issues with the affected certificates and websites, and replacing these certificates will not help. Symantec is a strong supporter of Google Chrome and its Certificate Transparency (CT) policies. This is entirely a bug with Certificate Transparency handling that is only present in Chrome 53.  

The recommended solution is to upgrade to Chrome 54 while Google is working on a patch to resolve this issue. Other browsers (i.e., Safari, Microsoft IE, Edge, Firefox, etc.) are unaffected by this bug.

This blog has been updated here.

  • Products
  • TLS certificate
  • SSL
  • CT
  • chrome
  • DigiCert SSL TLS Certificates
  • Products and Solutions